Kunaljain's Weblog

October 9, 2009

Error:- Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.4.2-4.el5_3.1.i386

Filed under: Linux Tips & Tricks — Kunal Jain @ 12:04
Tags: ,

While installing subversion on my CentOS 5.2 64bit OS i got this error

yum install subversion
Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.4.2-4.el5_3.1.i386

I google the error and found the solution.

  • Fistly i download perl(URI) which is greater than 1.17. I downloaded perl(URI) 1.35 using the following command
wget http://yum.trixbox.org/centos/5/RPMS/perl-URI-1.35-3.noarch.rpm
  • Then i install the perl package by using following command
rpm -i perl-URI-1.35-3.noarch.rpm
  • Then i install the subversion by using following command
yum install subversion

Now subversion is working fine on my server.

Advertisements

3 Comments »

  1. You just saved me a ton of headache. I am very thankful.

    Comment by A Happy Camper — November 10, 2009 @ 19:01 | Reply

  2. You saved me a headache too!

    Comment by Happy — February 4, 2010 @ 22:55 | Reply

  3. You have saved my life!. Thx you

    Comment by Anto — March 15, 2010 @ 14:18 | Reply


RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at WordPress.com.

%d bloggers like this: