Kunaljain's Weblog

October 9, 2009

Error:- Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.4.2-4.el5_3.1.i386

Filed under: Linux Tips & Tricks — Kunal Jain @ 12:04
Tags: ,

While installing subversion on my CentOS 5.2 64bit OS i got this error

yum install subversion
Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.4.2-4.el5_3.1.i386

I google the error and found the solution.

  • Fistly i download perl(URI) which is greater than 1.17. I downloaded perl(URI) 1.35 using the following command
wget http://yum.trixbox.org/centos/5/RPMS/perl-URI-1.35-3.noarch.rpm
  • Then i install the perl package by using following command
rpm -i perl-URI-1.35-3.noarch.rpm
  • Then i install the subversion by using following command
yum install subversion

Now subversion is working fine on my server.

Blog at WordPress.com.